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Chapter 1
Introduction
This section includes the following topics:

■ Utilities Included with the System ■ Starting the Utilities

Utilities Included with the System
This guide describes the following software utilities provided with the SLS system:

■ Remote Notification, which can tell 
you when builds finish or problems 
occur, by pager or e-mail

■ Remote Status, which checks the 
status of the SLS system from a 
remote system

■ Gettimes, which summarizes 
important time data from a build’s 
states.blog file

■ Build Report, which extracts selected 
information from the build packet and 
the states.blog file in a spreadsheet 
format

■ The Scale-Offset II and Runtracker 
workbooks, which generate and track 
scale and offset data 

■ STL Optimization utility, which 
reorganizes STL files so that they 
load and display faster

Gettimes, Build Report, Scale-Offset II, Runtracker, and STL Optimization Utility can 
be used immediately upon installation. Remote Notification and Remote Status 
require some setup and configuration to be useful. The sections that follow describe 
each utility in more detail.
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Starting the Utilities
All of the utilities except Gettimes, Scale-Offset II, and Runtracker can be found on 
your Windows Start menu. To use the menu, select Start→ Programs→ Dtm. The 
Dtm menu appears. Select a utility from the menu to start it.

To start the Gettimes utility, use Windows Explorer to display the c:\dtm\bin directory 
and find the Gettimes.exe file. Double-click the filename. There are also several 
command-line options you can use with Gettimes; to issue command-line options, 
you must run Gettimes from an MS-DOS window. See “Gettimes” on page 40 for 
more information.

For information on starting Scale-Offset II and Runtracker workbooks, see “How to 
Use the Workbooks” on page 60.



Chapter 2
Remote Notification
The Remote Notification utility allows you to notify people via pager or e-mail when 
certain events occur during use of the SLS system. You can also have events trigger 
application programs or operating system commands.

The Remote Notification utility runs on the SLS system. It requires access to a 
modem, either locally or through a network.

This section includes the following topics:

■ Starting the Remote Notification 
Utility

■ Setting Up Remote Notification
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Starting the Remote Notification Utility
To start the Remote Notification utility, select Start→ Dtm→ Remote Notify. The 
RemoteNotify window appears.

Figure 1. RemoteNotify Window

Activating and Deactivating the Utility
When you start the application, it is active, meaning it will send notifications. If you 
want to temporarily disable notification while the application is running (for example, 
to make changes to notification options), select File→ Deactivate. The words “Not 
Active” appear in the status bar at the bottom of the window. To activate the utility 
again, select File→ Activate. 

Toolbar

List of 
event 
types

Columns for 
consequences

Shows 
whether the 
utility is 
currently 
active
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Setting Up Remote Notification
Before you can use the Remote Notification utility, you must perform several setup 
tasks. These include selecting events that you want to be notified of, and entering the 
pager numbers, e-mail addresses, and application programs that you want the 
program to use when an event occurs.

Settings and Data Files 
The Remote Notification utility stores two kinds of information: settings files and data 
files. Settings files store your choices of what events should cause someone to be 
notified and how they should be notified. They use the .cfg extension. Data files store 
names, e-mail addresses, and codes. They use the .dat extension. Both types of files 
are stored in the c:\dtm\config\RemoteNotify directory. 

You can have several settings files, but each accesses the same Address Book for e-
mail addresses and Code Book for pager codes.

After you start entering setup information, you should save a settings file by selecting 
File→ Save or clicking . 

When you initially start the utility, the settings file is untitled.

You can load an existing settings file by selecting File→ Open or clicking .

✏The Remote Notification utility keeps a list of recently-used settings files on the File menu.

Events and Consequences
Remote Notification is based on events and consequences. Consequences are the 
actions the Remote Notification utility takes when a specific type of event occurs. 

The events that can trigger consequences include:

■ Alarms, warnings, and advisories: You can select different consequences for each 
of these three types of messages.
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■ Inert reached: The system has inerted the process chamber.

■ Stages and completion: You can select consequences for the system’s entry into 
each of the three build stages (warm-up, cool-down, and build) as well as for build 
completion.

✏Remote Notification will send a build complete message whether the build ends normally or 
due to a problem.

■ Z heights reached: You can select consequences for the system to apply when the 
build reaches specific Z heights. See “Setting Up Z-Height Triggers” on page 28 
for more information.

For each type of event, you can select the following consequences:

■ The utility pages one or more persons.

■ The utility sends e-mail to one or more persons.

■ The utility runs one or more programs.

■ Any combination of the above.

Selecting Consequences
The RemoteNotify window contains a table with a row for each type of event. In each 
row, you can select a check box for each type of consequence. For example, the 
following figure shows the RemoteNotify window with Pager and Mail consequences 
selected for Alarm events: 
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Figure 2. RemoteNotify Window with Consequences Selected

In addition to selecting the check boxes, you must set up the details of each 
consequence as described in the sections that follow.

Printing Settings
You can print the table of settings and consequences shown in the RemoteNotify 
window by selecting File→ Print or clicking .

Check boxes 
indicate that 
Alarm events 
will trigger 
Pager and Mail 
consequences
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Figure 3. Sample Settings Printout

Setting Up Pager Notification
To use pager notification, you must:

1. Set up the modem server.

2. Set up the pager. 

3. Create a phone book

4. Create a code book.

5. Create pager lists for each event that should result in someone being paged.

The sections that follow describe each of these steps in detail.

Setting Up the Modem Server
Before you can use the pager notification features of the Remote Notification utility, 
you must install and run the Modem Server software on a computer with a modem. 
The modem server software is included on the SLS systems software CD. You can 
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use a modem connected to the SLS system directly, or a network modem, as shown 
in Figure 6.

Installing the Modem Server

✏The Modem Server software is installed on all SLS systems. If you intend to use a network 
modem rather than a modem installed in the SLS system computer, the Modem Server 
software must be installed on the computer that has the network modem.

To install the modem server, perform a standard SLS system software installation as 
described in “Installing or Uninstalling the Software” in Chapter 3 of your Reference 
Guide. The modem server is automatically installed as part of the system.

Running the Modem Server

After you complete the installation, run the ModemServer.exe program located in 
c:\dtm\bin. The DTM Modem Server window appears:
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Figure 4. DTM Modem Server Window

Select a modem by clicking the Select Modem button and make a selection from the 
drop-down list in the dialog box that appears. 

The DTM Modem Server application must be running before you start the Remote 
Notification application. It must remain running at all times while the Remote 
Notification application is running.

✏After you run the Modem Server, find out the IP address of the computer with the modem so 
that you can use it in setting up the pager. Determine if your network uses dynamic 
addressing, and if it does, ask your system administrator to set a static address for the 
computer with the modem.

Click this 
button to 
select a 
modem
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Setting Up the Pager
To set up the pager, start Remote Notification and select Edit→ Pager Setup. The 
Pager Setup dialog box appears. Enter appropriate values in the two text boxes.

Figure 5. Pager Setup Dialog Box 

Modem IP Address  is the internet protocol (IP) address of a computer with a 
modem. This computer must be running the DTM Modem Server application as 
described in “Setting Up the Modem Server” on page 8.

✏Avoid using the IP address 192.88.202.1, which is reserved by the SLS system for use in 
communicating with its internal scanner computer.

Enter the IP 
address of a 
computer that 
has a modem 
and is running 

Use the 
default value
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Figure 6. Possible Modem Configurations and IP Addresses

Socket Port  is the address of the modem interface application that handles paging 
requests from the Remote Notification utility. 

✏Use the default Socket Port number unless instructed to change it by 3D Systems.

Network
Modem

Use IP address of the computer 
with the modem in the Pager 
Setup dialog box

Network modem

Local modem
Use the self-referential IP address 
127.0.0.1 in the Pager Setup dialog box

Modem connected 
directly to the 
application computer
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Creating a Phone Book
A phone book provides a list of phone numbers that you can page from the Remote 
Notification utility. To create a phone book for your company:

1. Select Edit→ Phone Book.

The Edit Phone Book dialog box appears.

Figure 7.  Edit Phone Book Dialog Box 

2. For each phone number you want to add to the phone book, complete the 
following steps:

a. Click the Add button.

The Edit Phone Book Entry dialog box appears.

Click the Add 
button to display a 
dialog box where 
you can add 
names and pager 
numbers

Select a name, 
then click the 
Edit button to 
change a name 
or pager 
number
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Figure 8.  Edit Phone Book Entry Dialog Box 

b. Enter appropriate information in the Name, Phone Number, and Pager Delay 
text boxes.

✏ If a prefix, such as the number 9, must be dialed first to get an outside line from your hone 
system, include it in the Phone Number text box—even if you have already set up the prefix for 
an outside line in the Telephony control panel.

c. Click the OK button.

The new phone book entry appears in the Edit Phone Book dialog box, listed 
by name.

3. To make changes to any phone book entry, select the entry in the list on the Edit 
Phone Book dialog box, then click the Edit button.

The Edit Phone Book Entry dialog box appears. Make any needed changes in the 
text boxes, then click the OK button.

4. To delete an entry, select the entry in the list, then click the Delete button.
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5. When you are finished making changes to your phone book, click the OK button 
on the Edit Phone Book dialog box.

Creating a Code Book
A code book in Remote Notification is a list of codes that the utility can send to pager 
numbers. A code is a string of numbers. You give each code a name in the code book 
for your reference, but only the numbers are sent to the pager.

✏Some number sequences will not work with some pagers; you should manually test all codes 
before using them in a code book.

Choose codes that are easy to recognize and make sure you communicate their 
meanings to the recipients before using. The following list gives some sample codes 
you might use:

You create a code book in the same way that you create a phone book. Select Edit→ 
Code Book, then continue with step 2 of the procedure in the preceding section. Read 
all references to “Phone Book” as “Code Book.”

Creating Pager Lists
You can create a pager list for each event type. This list defines the pager numbers 
that will be dialed if an event of that type occurs. To create a pager list:

Code Name Code

Alarm 911

Warm-up Stage 1

Build Stage 11

Cool-down Stage 111

Build Complete 1111
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1. Double-click a cell in the Pager column of the Remote Notification window.

Figure 9. Displaying the Paging List

The Paging List dialog box appears. 

Double-click 
this cell to 
display the 
Alarm 
Paging List
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Figure 10.  Sample Paging List Dialog Box

✏You can also display the list by selecting the cell and then pressing the right trackball button, or 
by selecting the cell and selecting Edit→ Pager List.

2. Add names and select a code for each name.

a. To add names to the To be paged list, select an entry from the Phone Book list 

and click . Repeat until all the people you want to page are on the list.

b. To select codes, first select a name in the To be paged list, then select a code in 
the Select/Change Code list. 

To change the 
assigned code for a 
name, select the 
name in the To be 
paged list 

Select a name 
from the Phone 
Book list

Then click the 
right arrow button 
to move the name 
to the To be paged 
list

Names in list are 
displayed next to 
the code that will 
be sent for that 
name

Then select 
a code for 
the name
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Each name in the To be paged list can have one code that will be sent to its 
pager when the appropriate event occurs.

3. If desired, click the Send Test Page button. 

4. Click the OK button.

Setting Up E-Mail Notification
The Remote Notification utility can send e-mail to a different list of recipients for each 
event type. The e-mail message that the utility sends contains the type of event, the 
name of the computer sending the message, the text of the message, and a time 
stamp. For example:

Alarm from DTM17

The PLC has stopped executing

Monday, Apr 15 09:10:07 1998

To use e-mail notification, you must:

1. Set up e-mail.

2. Create an address book.

3. Create mailing lists.

The sections that follow describe each of these steps in detail.

Setting Up E-Mail
To set up e-mail, select Edit→ Mail Setup. The Mail Setup dialog box appears. Enter 
appropriate values in the two text boxes.
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Figure 11. Mail Setup Dialog Box 

Mail Server  is the domain name of your mail server.

“From” Address  is the address that will appear in the From header on the e-mail sent 
by the Remote Notification utility. This can be any text string and does not have to be 
a valid e-mail address. If it is not a valid e-mail address, recipients will not be able to 
reply to e-mails sent by the utility. 

✏You may want to enter the address of a system administrator or SLS system technician so that 
replies go to someone equipped to handle them, or you may want to enter a nonexistent 
address so that no replies are possible.

Creating an Address Book
An address book is a list of addresses to which the Remote Notification utility can 
send e-mail. It works much like the Phone Book and the Code Book that you create to 
use with pagers. To create an address book for your company:

1. Select Edit→ Address Book.

The Edit Address Book dialog box appears.
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Figure 12.  Edit Address Book Dialog Box 

2. For each e-mail address you want to add to the book, complete the following 
steps:

a. Click the Add button.

A secondary Edit Address Book dialog box appears.

Click the Add button to 
display a dialog box 
where you can add 
names and e-mail 
addresses

Select a name, then 
click the Edit button to 
change a name or e-
mail address
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Figure 13.  Secondary Edit Address Book Dialog Box 

b. Enter appropriate information in the Display Name and Email Address text 
boxes.

c. Click the OK button.

The new address book entry appears in the Edit Address Book dialog box, 
listed by name.

3. To make changes to any address book entry, select the entry in the list on the Edit 
Address Book dialog box, then click the Edit button.

The Edit Address Book Entry dialog box appears. Make any needed changes in 
the text boxes, then click the OK button.

4. To delete an entry, select the entry in the list, then click the Delete button.

5. When you are finished making changes to your address book, click the OK button 
on the Edit Address Book dialog box.

Enter the name 
that will appear 
in the address 
book list

Enter the 
actual e-mail 
address
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Creating Mailing Lists
You can create a different mailing list for each event type. This list defines the e-mail 
addresses to which mail will be sent if an event of that type occurs. To create a 
mailing list:

1. Double-click a cell in the Mail column of the Remote Notification window.

Figure 14. Displaying the Mailing List

The Mailing List dialog box appears. 

Double-click 
this cell to 
display the 
Alarm Mailing 
List
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Figure 15.  Sample Mailing List Dialog Box 

✏You can also display the list by selecting the cell and then pressing the right trackball button, or 
by selecting the cell and selecting Edit→ Mailing List.

2. Select a name in the Address Book list and click  to move it to the To list.

3. Repeat step 2 until all desired names are in the To list.

4. If desired, click the Send Test Message button. 

5. Click the OK button.

Setting Up Programs
You can have the Remote Notification utility launch programs or issue commands 
when specific types of events occur. 

Select 
a name

Click 
button
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To use these features, you must:

1. Create a program book.

2. Create program lists.

The sections that follow describe each of these steps in detail.

Creating a Program Book
A program book is a list of programs and/or system commands that you can have the 
Remote Notification utility launch. It works much like the Phone Book, the Code Book, 
and the Address Book. (Programs and system commands are treated the same by 
the Remote Notification utility.)

To create a program book for your company:

1. Select Edit→ Program Book.

The Edit Program Book dialog box appears.
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Figure 16.  Edit Program Book Dialog Box 

2. For each program you want to add to the book, complete the following steps:

a. Click the Add button.

A secondary Edit Program Book dialog box appears.

Click the Add button to 
display a dialog box where 
you can add program 
names and commands

Select a name, 
then click the 
Edit button to 
change a name 
or command
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Figure 17. Secondary Edit Program Book Dialog Box 

b. Enter appropriate information in the Display Name and Command Line text 
boxes.

c. Click the OK button.

The new program book entry appears in the Edit Program Book dialog box, 
listed by name.

3. To make changes to any program book entry, select the entry in the list on the Edit 
Program Book dialog box, then click the Edit button.

The Edit Program Book Entry dialog box appears. Make any needed changes in 
the text boxes, then click the OK button.

4. To delete an entry, select the entry in the list, then click the Delete button.

5. When you are finished making changes to your program book, click the OK button 
on the Edit Program Book dialog box.

Creating Program Lists
You can create a different program list for each event type. This list defines the 

Enter name 
to display in 
program list

Enter command 
line to run when 
event occurs
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programs that will be launched if an event of that type occurs. To create a program 
list:

1. Double-click a cell in the Run Program column of the Remote Notification window.

Figure 18. Displaying the Program List

The Program List dialog box appears. 

Double-click this 
cell to display 
the Alarm 
Program List
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Figure 19.  Sample Program List Dialog Box 

✏You can also display the list by selecting the cell and then pressing the right trackball button, or 
by selecting the cell and selecting Edit→ Program List.

2. Select a name in the Program Book list and click  to move it to the Run list.

3. Repeat step 2 until all desired names are in the To list.

4. Click the OK button.

Setting Up Z-Height Triggers
You can use Z-height triggers to select points in a particular build at which you want 
specific consequences to occur. To set up Z-height triggers:

1. Select Edit→ Z Height Triggers.

The Edit Z Height Triggers dialog box appears.

Select a program 
from the list

Click this button 
to move the 
program to the 
Run list
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Figure 20.  Edit Z Height Triggers Dialog Box 

2. Type a number in the New Z Height text box and click the Add button.

Each Z height that you enter will trigger a Z Heights Reached event, and produce 
the consequences you have selected for that type of event.

3. Repeat step 2 until you have entered all desired Z heights.

4. Click the OK button.

Type a number 
in the text box

Click the 
Add button

Absolute Z 
heights, measured 
from beginning of 
Warm-up stage
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Remote Status
The Remote Status utility allows you to check the status of a build or view 
temperatures and parameters for the SLS system via a dial-up connection or through 
a computer connected to your SLS system computer across a network.

This section includes the following topics:

■ Features of Remote Status

■ Installing the Utility on a Client 
System

■ Connecting and Starting the Utility

■ Using the Remote Status Utility
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Features of Remote Status
The Remote Status utility’s window looks similar to the standard SLS system 
software main window. It connects to a host system (a system connected to an SLS 
system and running the SLS system software) and displays a view-only version of the 
host’s window on your client system (one connected to the host via a network, and 
running the Remote Status utility).

The following figure shows the Remote Status application after you have connected 
to a host system that is currently building parts:

Figure 21. Remote Status Application When Connected

✏ If the host system is in Manual Operations mode, the application displays the Manual 
Operations dialog boxes as soon as they are displayed on the host.

You can distinguish this window from the 
ordinary main window by the words 
Remote Status in the title bar.

Display Status 
window to check 
machine details

Track important 
build data with the 
Build Parts window

Messages 
generated after you 
connect to the host 
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Installing the Utility on a Client System
✏You can install the Remote Status utility on any Windows 95, 98, NT, 2000, or XP system 

connected to your SLS system via a network.

✏3D Systems believes that the Remote Status utility will work on a Windows 98 system; 
however, this configuration has not been tested.

To install Remote Status, perform a standard SLS system software installation as 
described in “Installing or Uninstalling the Software” in Chapter 3 of your Reference 
Guide. 

Changing Your Font Setting
If dialog boxes displayed in the Remote Status utility look unusual to you, your 
system’s display font setting may be set to Small Fonts. The SLS system software 
interface is designed to use the Large Fonts setting. To correct this situation:

1. Click your right trackball button on the background of your desktop. 

A popup menu appears. 

2. Select Properties from the popup menu.

The Display Properties dialog box appears. 
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Figure 22. Display Properties Dialog Box

3. Select the Settings tab.

4. Select the Large Fonts setting. 

5. Click the Apply button.

You will need to restart your computer system before the new settings will take 
effect.

Settings tab

Font Size setting
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Connecting and Starting the Utility
Before you can start the Remote Status utility, you must be connected to the host 
computer through a network or through a dial-up connection. If you plan to use a 
dial-up connection, perform the dial-up and connect to your normal server before 
you run the utility.

To start the Remote Status utility, click on the Remote Status menu option. You can 
find this option in your Windows Start menu, on the DTM submenu.

The Remote Status window and the Connection dialog box appear:

Figure 23. Connection Dialog Box

Select a host name from the list in the Host name box (click the down arrow to see a 

Select a 
Host 
name or 
enter an 
IP 
address

Then click the 
Connect button

You can click here to 
display a list of previously-
used hosts
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list) or enter the IP address of the host system. Then click the Connect button. 

✏Use the default Socket Port number unless instructed to change it by 3D Systems. 

After you click the Connect button, the system attempts to make a connection and if 
successful, displays the Remote Status window.

Managing Host Information
You can store host information with the Connection dialog box so that you do not 
have to memorize IP addresses. To store a host IP address, start the utility to display 
the Connection dialog box. Click the New button and enter a host name in the Host 
name box. Enter the IP address in the IP address text box. Finally, click the Save 
button.

Use the Delete button to remove a host name from the list. 
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Using the Remote Status Utility
You can use the Remote Status utility in the following ways:

■ To track a build

■ To check parameters in a Status window

Tracking a Build with Remote Status

To track a build on a host system, click  after you launch the Remote Status utility. 
If the host system is building parts, the Build Parts window appears in your Remote 
Status window. This window is a duplicate of the host system’s Build Parts window. If 
the host system is not building parts, the application tells you that.
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Figure 24. Build Parts Window in Remote Status Utility

If the host system is not currently running a build when you click , the system 
displays the message SinterStation is not currently building.

✏The Build Viewer window is not available from the Remote Status utility.

Current build stage

Current temperatures
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Viewing a Status Window with Remote Status
Status windows in the Remote Status utility operate just as they do in the SLS system 
software. To open a Status window, select Machine→Status from the main menu or

click . A Status window appears. For more information on Status windows, see 
Chapter 5, “Using Status Windows”  in your Reference Guide.

Figure 25. Status Window

Viewing Manual Operations
If Manual Operations dialog boxes are being used on the host system while you are 
connected to it via the Remote Status utility, the dialog boxes will be mirrored in your 

Select a category 
on the left

The system 
displays an 
appropriate list 
of messages on 
the right
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Remote Status window. You can view the values and settings in the dialog boxes, but 
you cannot activate any of the functions from the Remote Status utility.

Message List Window
The message list window displays messages generated during the time that your 
client system has been connected to the host. Messages generated before you 
connected cannot be displayed.
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Gettimes
The Gettimes utility runs on the SLS system computer. It creates a brief report from 
the detailed information recorded in the states.blog file. It reports the times required 
for adding a powder layer, loading the scanner, sintering a layer, and slicing a layer, as 
well as total stage times for the warm-up, build and cool-down stages. 

The Gettimes utility operates by reading the states.blog (in the c:\dtm\logs directory) 
file and outputting its report to a file named time.data.
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Running Gettimes
You should start the Gettimes utility from an MS-DOS Command Prompt window 
within the Windows environment. 

1. To display an MS-DOS Command Prompt window, display the Start menu. Look 
for the  option and select it.

An MS-DOS Command Prompt window appears.

2. Change to the c:\dtm\bin directory.

Your prompt should show you the current directory. 

Type cd c:\dtm\bin and press Enter. 

3. In the window, type gettimes and press Enter. 

The system displays the following message:

Get Build Times Version x7.0

Command-line Options
There are three command-line options available with Gettimes. To use these options, 
you type additional information after the command name in the MS-DOS Command 
Prompt window.

✏You can use any of these options in combination and in any order; type a space between each 
option.

-i
The -i option is used to change the name of the input file. To use this option, type the 
filename after the -i with no intervening spaces. For example, to cause the Gettimes 
utility to use a file named OurMachineState.blog as input instead of the default 
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states.blog, type the following command:

gettimes -iOurMachineState.blog

If the new input file is not in the current directory, you must give the full pathname.

-o 
The -o option is used to change the name of the output file. As with -i, type the 
filename after the -o with no intervening spaces. For example, to send the output to a 
file named MyTimes instead of the default time.data, type the following command: 

gettimes -oMyTimes

-f 
Using the -f option causes Gettimes to include time values for each individual action,
such as adding a powder layer or loading the scanner, rather than the default method 
of printing a summary of the total time spent in these actions.
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Sample Output
The following text shows sample output from running Gettimes:

Start inert, TIME = Mon Nov  9 11:21:07 1998
Inert reached, TIME = Mon Nov  9 11:31:28 1998
     Time to inert = 0:00:10:21
New stage: Build setup, TIME = Mon Nov  9 14:05:27 1998
Start build: /usr2/sls2k/build/cpCallaway1.ja, TIME = Mon Nov  
9 14:05:37 1998
Start inert, TIME = Mon Nov  9 14:05:42 1998
Inert reached, TIME = Mon Nov  9 14:05:49 1998
     Time to inert = 0:00:00:07
     Time in stage = 0:00:00:29
New stage: Warmup, TIME = Mon Nov  9 14:05:56 1998
     Time in stage = 0:02:13:56
New stage: Build, TIME = Mon Nov  9 16:19:52 1998
     Time in stage = 0:00:08:17
End of build stage:
      Total slice time = 0:00:00:26
      Total time waiting on the slicer = 0:00:00:00
      Total add layer time = 0:00:02:10
      Scanner load time overlapped with sintering/add powder 
layer = 0:00:01:03
      Scanner load time not overlapped with sintering/add 
powder layer = 0:00:00:00
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      Total sinter time = 0:00:06:00
      Total wait for temperature time = 0:00:00:00
      Total paused time = 0:00:00:00
End of build, TIME = Mon Nov  9 16:28:09 1998
     Total build time = 0:02:22:32
New stage: Build setup, TIME = Mon Nov  9 16:28:13 1998
Start build: /usr2/sls2k/build/cpCallaway2.ja, TIME = Mon Nov  
9 16:28:22 1998
Start inert, TIME = Mon Nov  9 16:28:25 1998
Inert reached, TIME = Mon Nov  9 16:28:32 1998
     Time to inert = 0:00:00:07
     Time in stage = 0:00:00:35
New stage: Build, TIME = Mon Nov  9 16:28:48 1998
     Time in stage = 0:15:04:32
End of build stage:
      Total slice time = 0:00:24:21
      Total time waiting on the slicer = 0:00:00:00
      Total add layer time = 0:03:57:49
      Scanner load time overlapped with sintering/add powder 
layer = 0:03:54:41
      Scanner load time not overlapped with sintering/add 
powder layer = 0:00:00:11
      Total sinter time = 0:11:05:28
      Total wait for temperature time = 0:00:00:46
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      Total paused time = 0:00:00:00
New stage: Cooldown, TIME = Tue Nov 10 07:33:20 1998
     Time in stage = 0:05:02:31
End of build, TIME = Tue Nov 10 12:35:51 1998
     Total build time = 0:20:07:29



Chapter 5
Build Report
The Build Report utility extracts build information from SLS system log files and build 
packets. The files produced by the utility can be imported into a spreadsheet 
application for further manipulation.

✏You must have SLS system log files and build packets available to use with the Build Report 
utility. If you intend to create reports, make sure you do not delete the log files when you finish 
a session with the SLS system software.

This section covers the following topics:

■ Generating Reports ■ Using Reports
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Generating Reports
To generate a custom report:

1. Start the Build Report utility.

You can start the utility by clicking a button on the summary dialog box that 
appears at the end of a build, or from the Start menu. From the Windows Start 
menu, select Start→ Programs→ SLS System→ Build Report. The SLS Build 
Report utility window appears.

 

Figure 26. Build Report Utility Window

2. Display the Preferences dialog box by selecting Edit→ Preferences.

3. Select the information you want in your report in the Preferences dialog box.

See Figure 27., “Preferences Dialog Box,” on page 49.

Select a build 
packet (click the 
arrow to display 
a list of all build 
packets in the 
current log file)

Information 
about the 
selected build 
packet
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The Preferences dialog box has three tabs. Click on a tab to change the options 
that are displayed. Each option has a check box. By default, most of the options 
are already checked. Click on a check box to check or uncheck that option. The 
system remembers your option choices the next time your run the utility, so if you 
repeatedly run the same kinds of reports, you need only select your options once.

The available options include build parameters, part parameters, and build times. 
See Figure 27 for more information on build times.

When all the options in all three tabs are set the way you want, click the OK button 
to return to the SLS Build Report utility window.
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Figure 27. Preferences Dialog Box

Preferences 
dialog box

Click on tabs to 
select a set of 
options

Click on check 
boxes to turn 
options on or off
(checked 
parameters are 
included in reports)

Build Times 
options

Select either Time 
Summaries or 
Detailed Times

If you select 
Detailed Times, 
select which of the 
listed options you 
want to appear in 
your report
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4. Select a log file if needed.

The application automatically loads the log file in the c:\dtm\logs directory, if one 
exists. If you want to use a different log file, select File→ Select log file and use the 
Open dialog box to locate the file.

5. Save your report.

Select File→ Save build data. The Output Options dialog box appears.
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Figure 28. Output Options Dialog Box

6. Select the output options you want, as shown in Figure 28.

7. Click the OK button.

For each build selected, a file appears in the designated output directory (the default 
directory is \dtm\logs). Each output file’s name uses the format 

Select an output directory 
by typing in the text box or 
clicking the Browse button

Select the delimiter 
(separator) for fields in 
the report

Select whether you want 
the report to include all of 
the build packets or only 
some of them

If you chose the Output 
selected packets option, 
select packets in this list. 
For each packet you 
select, a separate report 
file is generated.

Click the 
OK button 
to save 
your report 
to the 
output 
directory
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buildpacketMMDDTTTT.rpt, where

buildpacket  is the build packet file name minus the .bpf extension

MM  is the number of the month

DD  the day

TTTT  the time when the build started.

For example, a report from a build packet named newmold.bpf built on February 2 at 
11:02 a.m. would have the filename newmold02021102.rpt.

✏ If you change your preferences and save a report again without changing the output location, 
the new report will overwrite the old one. 
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Using Reports
The reports generated by the Build Report utility are text files with fields separated by 
either commas or tabs, depending on the delimiter you chose in the Output Options 
dialog box. These reports are designed to be imported into a spreadsheet or 
database application. You can use these reports to record the part parameters for 
each part in a build for later reference, or to track build and part parameters over 
time. This data can be used to improve part accuracy or to keep track of optimum 
parameters for builds. Figure 29 shows the basic format of a report generated by the 
utility.

✏Build Report outputs all measurements in inches, because all values in the states.blog file are 
stored in inches. You can convert values to millimeters in your spreadsheet program if desired.
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Figure 29. Report Format

Summary Build Report:

Build started: 08/24/99  17:01:02

Build ended: 08/24/99  17:12:10

Build packet: 
C:\dtm\build\1bc_verified.bpf

Material: DuraForm Polyamide

Platform: SLS2500PLUS

All distance units are in inches

             Part names: bc1.stl_
1

bc1.stl_
2

Profiled part parameters Z-
height Value Z-

height Value

  Fill Jump Delay 0 500 0 500

  Fill Jump Speed 0 339.08 0 339.08

  Fill Laser Off 0 1500 0 1500

  Fill Laser On 0 1124 0 1124

  Fill Scan Delay 0 36 0 36

General build 
information

Table of part 
parameters

Table of 
rotation/scale 
factors

Build 
parameters 
by stage

Build times

Build 
heights



Chapter 6
Scale-Offset II and DTMRuntracker 
Workbooks
This section describes the Scale-Offset II and DTMRuntracker workbooks. These are 
Microsoft Excel workbooks you can use to generate scale and offset values and track 
information about builds or parts over time.

✏You can now purchase scale and offset calculation tools from 3D Systems that replace and 
improve on the functions provided by these workbooks. See the Scale Calculation Tools 
section of your Build Setup Help.

This section covers the following topics:

■ Minimum System Requirements

■ Uses for the Scale-Offset II Workbook

■ Uses for the DTMRuntracker 
Workbook

■ Setting Up the Workbooks

■ How to Use the Workbooks



Software Utilities Guide 56 Minimum System Requirements
Minimum System Requirements
The workbooks require a Windows computer system with Microsoft Excel installed 
(version 97 or later). 3D Systems recommends a system with a minimum of 128 MB 
of RAM and a 200 MHz or faster Pentium processor.

The system you use to run the workbooks does not need to be same one you use to 
run the SLS system.

Solver Add-In
Before you can use these workbooks, you must have installed the Solver add-in. This 
is a file that adds capabilities to Excel. It is not included in the default Excel 
installation. See the documentation that came with your copy of Excel or the on-line 
help for instructions on installing the Solver add-in.
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Uses for the Scale-Offset II Workbook
The Scale-Offset II workbook replaces previous methods for calculating scale and 
offset values. It allows you to use any part as a scale part; you can select a scale part 
based on the materials and geometries you are building. To scale a specific geometry, 
you can use the actual part—building it once, measuring it, and then generating scale 
and offset values to apply to future builds.

✏You do not have to build an initial part without using scale and offset values in order to use the 
worksheet. The worksheet can handle parts that were built with constant scale and offset. If 
you want to use higher-order scale values, use the Opti-Scale™ scale calculation tools, an 
optional module available for the Build Setup application.
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Uses for the DTMRuntracker Workbook
The DTMRuntracker workbook takes data from the Scale/Offset workbook and tracks 
changes over time. Some uses for this data include:

■ Monitoring day-to-day machine variability

■ Measuring scale and offset at predetermined intervals for a wide variety of 
geometries

■ Fine-tuning parameters when repeatedly building the same geometries
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Setting Up the Workbooks
You can find the two workbooks on the SLS system computer or on the SLS system 
software CD that came with your system. Use the latest release of the SLS system 
software. 

They are .xls files found in the geometry\Samples\scale directory. To set up the 
workbooks, copy them onto the hard-disk drive of the system you want to use them 
on, or onto a network drive. There are two versions of the Scale-Offset II workbook, 
one for Windows 2000 (ScaleOffset II 2000.xls), and one for Windows XP (ScaleOffset 
II XP.xls).

You must copy and rename the workbooks before you can use them. You may want 
to name the copies after the parts that you are measuring or the machines you are 
tracking.

✏When you open one of these workbooks, Excel may display a message indicating that the 
workbook contains macros and offering to disable them. Be sure to enable macros; the 
workbooks require them.
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How to Use the Workbooks
The following procedures outline how to use the workbooks. The first worksheet in 
each workbook contains detailed instructions for using the workbook.

To use the Scale-Offset II workbook for calculating scale and offset values:

1. Build a part and measure it.

The workbook calculates scale and offset values separately for each axis. For each 
axis that you want to scale, you will need at least three data points; 3D Systems 
recommends measuring at least five points.

You can use any part; see your Material Process Release Notes for 
recommendations.

2. Enter the nominal and measured dimensions into a copy of the Scale-Offset II 
workbook. Use the Data worksheet within the workbook.

✏The original Scale-Offset II workbook is a read-only file; you must make a copy using the 
operating system or Excel’s Save As feature before you can save changes.

✏You can use any units with the Scale-Offset II workbook, as long as you are consistent. If you 
enter values in inches, you will get inch values out; if you enter values in millimeters, you will 
get millimeter values out. However, you must convert the Tolerance value from the default 
(0.002 inches) to an appropriate value for the unit you are using; for millimeters, change the X, 
Y, and Z tolerance to 0.051.

3. Calculate the scale and offset values.

To find the scale and offset values for each axis, click the Calculate X Values, 
Calculate Y Values, and Calculate Z Values buttons in the Data worksheet.
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Figure 30. Scale/Offset II Workbook: Data Worksheet

To use the DTMRuntracker workbook to track scale and offset values:

1. Upload data from a copy of the Scale/Offset II workbook to a copy of the 
DTMRuntracker workbook.

✏The copy of the DTMRuntracker workbook that you plan to use must be closed when you 
upload data to it.

In the Scale/Offset II workbook’s Data worksheet, click the Upload X data to SPC, 
Upload Y data to SPC, and Upload Z data to SPC buttons in the Data worksheet.

✏You will have to scroll to the right in the Data worksheet to see the Upload buttons. 

2. Open the copy of the DTMRuntracker workbook.
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3. Verify your data, and delete any redundant data.

4. In each of the Plot worksheets within the DTMRuntracker workbook, click the 
Update Plots button.

5. If desired, perform additional correlation as described in the DTMRuntracker 
workbook.

A worksheet within the workbook, Correlation Data, is devoted to correlation 
analysis of variables and user-defined variables.

Figure 31. DTMRuntracker Workbook



Chapter 7
STL Optimization Utility
This section describes the STL Optimization Utility, an application that makes STL 
files load and display more quickly in the Build Setup application. It includes the 
following topics:

■ Why You Should Optimize Files

■ Using the STL Optimization Utility

■ How STL File Optimization Works
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Why You Should Optimize Files
Optimized files render and load up to 10 times faster than unoptimized files, and they 
remain valid STL files, editable by any application that accepts STL files 

✏ If you edit an STL file in any application other than Build Setup, you should re-optimize it 
afterward.

✏ If you optimize an STL file after using the Dimension Tool to establish nominal dimensions for 
use with the Scale and Offset Calculation Wizard, the nominal dimensions will no longer be 
valid and must be selected again. See your Build Setup Help for information on using these 
Scale Calculation Tools.

STL files are the input files used in the SLS process; STL files are created by 
computer-aided design (CAD) software.

When you add an STL file to a build, the Build Setup application checks to see if it has 
been optimized; if it has not, the application asks if you want to optimize it. In most 
cases, you will not need to use the STL Optimization Utility as a separate application. 
However, it can be useful if you want to optimize large numbers of files at once. 

If you want to know whether a particular file has been optimized, add the STL file to a 
build in the Build Setup application, then display the Information View and look at the 
Part Info tab. If it is optimized, the file’s File Type will be listed as Optimized Binary.



Software Utilities Guide 65 Using the STL Optimization Utility
Using the STL Optimization Utility
To use the utility to optimize one or more files:

Figure 32. STL Optimization Button on the Build Setup Toolbar

1. Start the utility from within the Build Setup application by selecting Tools→ 
Optimize STL Files, by clicking the appropriate icon on the toolbar, or from the 
Windows Start menu by clicking Start→ Programs→SLS System→ STL 
Optimization.

The 3D Systems STL File Optimization Utility window appears.

2. Select the STL files you want to optimize.

You can select any combination of files and/or directories.

STL Optimization button
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Figure 33. Selecting Files/Directories to Optimize

3. Click the Next button. 

An options window appears.

Select drive and 
directory

Select file or files

When you click 
this button, the 
utility adds the 
currently-
selected file or 
directory to the 
list on the right (if 
no file is 
selected, a 
directory is 
added)

To remove an 
item from the 
file/directory list, 
select it and click 
this button

Click the Next button 
when you have selected 
all the files you want to 
optimize 

File/directory list
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Figure 34. STL Optimization Utility Options Window

4. Select an option.

If you select the Append Suffix option, enter a suffix or accept the default “opt” 
suffix.

If you select the Put On Different Directory option, select an output directory.

5. Select or deselect the Do Not Do if Already Optimized check box.

This area is blank for the first 
option and displays an 
appropriate field when you 
select the second or third 
option

Select 
an 
option

Click the 
Do It 
button; a 
progress 
log 
appears 
in the 
large text 
box

Click here to 
enable removal 
of details that 
cannot be 
reproduced in 
the SLS system
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6. If you want the system to compress your STL files, select the Remove Small 
Facets check box. 

✏Since this option modifies your STL file, the system disables the Overwrite Original Files 
option if you select Remove Small Facets.

You can select a Lower Threshold setting to indicate when facets are too small to 
be useful.

7. Click the Do It button.

The utility processes the files and displays a progress log in the large text box on 
the window. The Do It button changes to a Cancel button while the utility is 
processing the files, then to a Close button when done. 

8. To process additional files, click the Previous button to return to the file/directory 
selection window. To quit, click the Close button.
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How STL File Optimization Works
Facets in most STL files are listed randomly. The STL Optimization Utility sorts the 
facets into an order that can be used by the Build Setup application to speed loading 
and display. It also removes unnecessary facets (facets that provide levels of details 
that cannot be reproduced in the SLS system) and combines some facets to reduce 
the file size and load times.

✏Although it may take several minutes to optimize a large STL file, the task only needs to be 
performed once. Also, you can optimize whole directories of STL files as a batch process, 
overnight or during other available down time.



Chapter 8
Session Log Files
This section describes session log files; “consolidated” log files created by the Sinter 
application that contain copies of all the separate error and parameter log files Sinter 
generates. Session log files have a “.3DL” extension (for “3D Log”) and are also called 
“3DL files.”

The topics in this section describe the contents of 3DL files and how and when Sinter 
generates them. 

■ About Session Log (3DL) Files

■ LogManager and Session Log Files

■ Session Log File Contents

■ How Sinter Generates Session 
Log Files

■ Summary – How Log Sessions Work

■ Session Log File Disk Space 
Management

■ Session Log File Descriptions
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About Session Log (3DL) Files
Log files can help you and 3D Systems refine and troubleshoot your SLS process. 
Sinter creates many separate log files during and between builds. They all have 
different file formats, names, and storage locations. Sinter also creates session log 
(.3DL) files to make it easy for you to access the data in these multiple log files. 

At the start or end of a build, Sinter copies the various log files created during the 
previous session into a 3DL file automatically or on demand so you can view, search, 
and manage them in LogManager.

Sinter copies log files to a...

■ Build session log file after an build completes or is terminated.

■ Manual Ops session log file between builds, just before a new build starts. 

✏ If you ever need to work with 3D Systems Customer Support to troubleshoot your SLS 
process, you can send your session log files for to review instead of gathering sending many 
different log files.

Sinter stores 3DL files in two folders on your installation drive by default: 
\dtm\3DLogs\Build and \dtm\3DLogs\ManualOps.

LogManager and Session Log Files
✏This topic is a general discussion. For complete details, see Chapter 10, “LogManager” .

Run the LogManager utility to open, view, and search the contents of session log 
files. LogManager is a stand-alone program; you can run it even if Sinter is not 
running. To open or view any log file in LogManager, click a 3DL file in the 
\dtm\3DLogs\Build or \dtm\3DLogs\ManualOps folder, or, run LogManager, then 
choose File > Open ... or File > Recent Build ... 
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You mainly use LogManager to do the following:
■ View the contents of the individual log files a 3DL file contains.

■ View historical parameter graphs with RealMonitor event notations. (RealMonitor 
License required).

■ Manage log file disk space by specifying how many 3DL files to keep, based on 
the file date or folder size.

■ (If Sinter is running…) initiate a new 3DL file for the current Build session or 
Manual Ops session on demand

✏You need to run Sinter at least once to create the first 3DL file automatically.

Session Log File Contents
Build session and Manual Ops session log files contain copies of the individual log 
error and monitoring log files that Sinter generates during and between builds. They 
also contain copies of the configuration and .ini files in use when the session log file 
was generated. 

The two tables below list the file names of the individual error and monitoring log  
files that Sinter copies into session log files. They also list the different types of data 
these log files contain.
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Error Log Files

Monitoring Log Files

Error Log File Name Contains...

Slicer.tlog Slicer program (Slicer.exe) runtime errors

Plcif.tlog PLC interface program (Plcif.exe) runtime errors

ScanIF.tlog Scanner interface program (Scanif.exe) runtime errors

DSPIF.log
(Sinterstation Pro SLS systems only)

Digital Signal Processor interface program (Dspif.exe) runtime errors

Packetio.log
(Should always be empty, if not, 
contact 3D Systems Customer 
Support)

Errors in:
■ material configuration (.cfg) files; <material_name>.cfg
■ machine configuration files; machine.cfg
■ Build packet files; <build_name>.bpz

Monitoring Log Files Contains...

States.blog All build, part, and scale parameter values

RealMonitor log (.rmt) file 
<MMDDYYbuild_name>.rmt 

The values of all parameters RealMonitor is monitoring

RealTimeCal.log Data for every Real Time Calibration event. For each calibration 
attempt, it logs whether calibration was successful or failed-and how 
much adjustment, if any, was applied—and why.

RealTimeCalData.log Summarizes each Real Time Calibration adjustment made

OfflineCal.log
(Only for offline calibration)

Records how much adjustment was applied during any Offline 
Calibration—and why the adjustment was applied

Bds.tlog All commands sent to the beam delivery system by the scanner 
interface software

Data.log A summary of each build, including the time the build finished, the 
material used, and the part and feed temperature set points.
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How Sinter Generates Session Log Files
While Sinter is running, it logs data to the individual log files in Session Log File 
Contents above regardless of whether a build is running or not. These individual log 
files are stored in folders separate from the \dtm\3DLogs session log file folder. 

On the other hand, Sinter starts a new session log file when a build starts, then closes 
the session when the build terminates. The log files generated during a build are 
called the Build Session Log. In between two builds, there will also be sets of log files 
generated. These log files are called the Manual Ops Session Log. 

Log Sessions
When a new session starts, individual log files are overwritten. This means individual 
log files on disk only contain data from the most recent session. Log data from older 
sessions resides in the (date/time-stamped) 3DL files to which individual log files are 
copied at the end of each session.

When a (Build or Manual Ops) log session closes, Sinter automatically adds all 
individual log files generated in the session that just closed to one compressed date/
time-stamped session log (.3DL) file. It then stores the 3DL file in either:

■ \dtm\3DLogs\Build if a build (“Build session”) just ended, or 

■ \dtm\3DLogs\ManualOps if a “Manual Ops session” just ended; i.e., a build just 
started
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Session log file names
When a build starts, Sinter closes the Manual Ops Log Session and creates a .3DL file 
with the file name 

machine ID_YYYY-MM-DD_HH.MM.SS_manual_ops<index#>.3DL

When a build finishes, Sinter closes the Build Log Session and creates a .3DL file with 
the file name:

machine ID_YYYY-MM-DD_HH.MM.SS_build packet name<index#>.3DL

Where:

machine ID is the SLS system’s serial number by default. However, if you entered a 
custom Machine Name in your RealMonitor Setting Preferences window, that will be 
the machine ID.

YYYY-MM-DD_HH.MM.SS is the date and time when the Log Session started. (Time is 
in 24-hour format.)

<index#> is a number appended to the file name to prevent duplicate file names.

✏A 3DL file name can be up to 256 characters long.

Generating Session Log Files Manually
Sinter generates 3DL files automatically when to start and finish a build. However, 
you might also want to use the LogManager utility to generate a 3DL file manually if:

■ When a build is terminated abnormally.

■ When user wants to generated a 3DL file before a session is finished.
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Summary – How Log Sessions Work
This topic summarizes the session log file actions Sinter performs when:

■ Sinter starts

■ A build starts

■ A build finishes

■ Sinter ends normally

■ Sinter ends abnormally

When Sinter starts
■ A new Manual Ops session starts (if Sinter terminated normally the last time you 

ran it...).  Any existing individual log files are overwritten. (The data in all of the 
previous individual log files was copied/saved in a 3DL file.) 

When a build starts
Sinter does the following when a build starts:

1. Closes the Manual Ops session.

2. Creates a [...]_manual_ops.3DL log file.

3. Starts a new Build Log session, overwriting data in the individual log files 
collected during the Manual Ops session it just closed.

When a build finishes
Sinter does the following when a build finishes:

1. Closes the Build session.

2. Creates a [...]_build packet name.3DL log file.
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3. Starts a new Manual Ops session, overwriting data in the individual log files 
collected during the Build session it just closed.

When Sinter ends normally
Sinter does the following when it ends normally:

1. Closes the Manual Ops session (which started after the last build ended).

2. Creates a [...]_manual_ops.3DL log file.

When Sinter ends abnormally
When Sinter terminates abnormally, the next time your run it, it does the following:

1. Creates a [...]_manual_ops.3DL file or a [...]_build packet name.3DL file—
depending on the state it was in when it terminated abnormally.

2. Sets the Sinter Termination Status in the 3DL file to Abnormal.

✏Sinter Termination Status is shown in the Summary window box on LogManager’s 
RealMonitor tab. See “Summary Windows – (RealMonitor Tab Only)” on page 102.

Session Log File Disk Space Management
Typical session log files range in size from 100 KB to 1000 KB (1 MB), so you must 
remove old 3DL files periodically. Use the Diskspace Manage tab in the RealMonitor 
utility’s Preferences dialog to set limits on the size and age of 3DL files on disk. (See 
RealMonitor “Setting Preferences” on page 91.)
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Session Log File Descriptions
This section describes the contents of build and manual ops session log files. It also 
shows how Sinter names automatically-generated 3DL files.

Build session log files
Sinter generates a build session log file when a build terminates. The build 3DL file 
contains all the log file data generated during that build. Build session log file names 
are of the format:
<buildname>MMDDYYYYHHMMSS_Build.3DL

where buildname is the build packet filename.

Manual Ops session log files
Sinter generates a manual ops session log file when a build starts. The manual ops 
3DL file contains all the log file data generated between two builds; specifically 
between the a Build End event and a Build Start event.

Manual ops session log file names are of the format:
<buildname>MMDDYYYYHHMMSS_ManualOps.3DL

where buildname is the build packet filename for the build that started.



Chapter 9
RealMonitor
This section describes RealMonitor, a Sinter application utility that enables you to 
collect (“log”) and review data about SLS system. RealMonitor starts when you start 
Sinter and stops when you exit Sinter. It logs data continually by default while Sinter 
is running, but you can pause or stop logging (then restart it) at any time.

With RealMonitor, you can watch data plots update in real time and compare 
parameters while your SLS system operates. After a build, use LogManager to view 
and analyze the data logged by RealMonitor and other Sinter software modules in the 
log files the Sinter application creates.

✏See “LogManager” on page 95 for further information.

This section includes the following topics:

■ RealMonitor License

■ Logging Data with RealMonitor

■ Comparing Parameters in 
RealMonitor

■ Zooming in X and Y

■ Printing Plots

■ Setting Preferences

■ Creating a Session Log File Manually



Software Utilities Guide 80 RealMonitor License
RealMonitor License
RealMonitor and LogManager are licensed applications. You only need one license—
a RealMonitor license—to make full use of both RealMonitor and LogManager.

You can log data about your system before you install a RealMonitor license, but you 
must install a license before you can view data plots in RealMonitor and LogManager. 

RealMonitor logs data whether you have a license or not. So, even if you don’t have a 
license, you can still send log files to 3D Systems Customer Support if you need help 
resolving problems.

Installing a RealMonitor License
To install a RealMonitor license, click the Enable button on the RealMonitor toolbar as 
shown in Figure 35 below.

Click to open the license dialog

Figure 35. RealMonitor, before enabling a license
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You can also install a RealMonitor license by running the 3D Systems software 
licensing utility from the Windows Start menu. Choose Programs > SLS System > 
Install 3D License, then select RealMonitor in the License For drop-down list.

✏ If you install 3D Systems LS Software and a RealMonitor license on a separate, stand-alone 
computer (to run the Build Setup application), you can view the parameter data plots in 
LogManager’s RealMonitor tab.

Click Next to display your SLS system’s Computer ID in the License window, along 
with a blank text box for your RealMonitor license Activation Password. Contact 
3D Systems Customer Support by email or phone and provide your Computer ID. 
3D Systems will provide you with a RealMonitor license Activation Password specific 
to your SLS system. Enter Your Activation Password in the License window.

What a RealMonitor License Enables
■ Without a RealMonitor license – you can use RealMonitor to log data during and 

between builds (which it does by default when you run Sinter), create 
consolidated 3DL Session Log Files, and manage the amount of disk space 3DL 
files use. In LogManager, you can open a 3DL file, then browse, search, and filter 
text data in individual Sinter log files without a RealMonitor license.

■ With a RealMonitor license – you can do everything above—plus view live data 
plots in RealMonitor and historical data plots in LogManager. The data plots show 
parameter values as a function of time or build z-height. These graphs include 
vertical lines showing when, or at what z-height, various build events occurred. 
You also get the option to overlay a moving average trend line.

In addition, with a RealMonitor license you can export data to a delimited file, as 
well as use a dynamic-link library (DLL) to access logged data in real time from a 
custom application program.
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Replacing a RealMonitor License
The license activation password will persist after an upgrade of the SLS system 
software. However, you will need to contact 3D Systems Customer Support to get a 
new password if you do either of the following:

■ Reinstall your operating system

■ Change your network configuration; (for example, if you replace your network 
card)



Software Utilities Guide 83 Logging Data with RealMonitor
Logging Data with RealMonitor
The RealMonitor utility starts automatically when you start the Sinter application. 
When you enter Build or Manual Ops mode in Sinter, RealMonitor opens a new Build 
or Manual Ops session (3DL) log file and starts logging data to many individual Sinter 
log files. It then copies the individual log files into time-stamped 3DL files at the end 
of the session. (See Chapter 8, “Session Log Files”  for further details.) 

One of the most important individual log files that gets copied into a 3DL file is the 
RealMonitor Log (.rmt) file. There are two types of .rmt files; one for Build data and 
one for Manual Ops data. This section describes both types of .rmt files, and various 
ways you can start and stop logging data to them. 

RealMonitor (.rmt) Log Files
Two Sinter log files store the values of all parameters RealMonitor can display on its 
data plots. They are: 

<BuildPacketName>.rmt – for the current Build session

ManualOps.rmt – for the current Manual Ops session

These two .rmt log files (and the other individual Sinter log files) are copied into the 
time-stamped 3DL session log file created at the end of each Build session and 
Manual Ops session. 

RealMonitor automatically logs data to <BuildPacketName>.rmt while Sinter is in 
Build mode. However, it does not automatically log data to ManualOps.rmt data in 
Manual Ops mode. To log data to ManualOps.rmt, you must click the Start button 
(see Figure 36., “Start, Stop and Pause buttons,” on page 84) when Sinter is in 
Manual Ops mode.
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Starting and Stopping Logging to a RealMonitor (.rmt) Log File
You can stop, pause, and restart logging data to 
either of the two RealMonitor (.rmt) Log Files at 
any time using the Start, Stop, and Pause 
buttons below the RealMonitor toolbar.

If you wish to start or stop logging to the 
current .rmt file when a specific event occurs, 
you have several events to choose from in the 
lists under Start Monitor At and End Monitor At (below the RealMonitor toolbar). 

After you select a Start or End event, specify the build height at which you want 
RealMonitor to begin watching for the event to occur.

Click these buttons to 
start, stop, or pause data 
logging to .rmt log files at 
any time.

Figure 36. Start, Stop and Pause buttons

Choose an event to Start Monitoring At or End 
Monitoring At from these drop-down lists.

Enter the build height at which you want 
RealMonitor to start watching for the selected 
Start or End event to occur.



Software Utilities Guide 85 Comparing Parameters in RealMonitor
Comparing Parameters in RealMonitor
The two parameter data plots RealMonitor displays allow you to view and compare 
SLS system parameters in real time. You can also scroll back in time (or z-height)—all 
the way back to the start of the current build—to compare parameters earlier in the 
build. For each parameter section, you select a parameter in the Plot Parameter list 
and the system graphs it on the right.

✏To compare more than two parameters at once, or to compare parameter values in older 
builds, use LogManager’s RealMonitor tab. You can compare more than two parameters by 
running multiple instances of LogManager and selecting different parameters to view in each 
instance. Then, for ease of comparison, use LogManager’s time synchronization function to 
synchronize the data displayed in each instance. (See “LogManager Log Tabs” on page 106 for 
more information.)
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Parameter Graphs and Plotting Options
Parameter graphs show a variety of data about a build.

Setpoint graphed in red alongside 
the parameter value, shown in black

Warm-up stage (pink)

Pause (grey)

Build stage
(green)

Event (change in build 
parameter); see Events

Build states are color-coded; cool-
down (blue) and 
build preparation 
(yellow) are not 
shown

Machine is 
idle (white)

Figure 37. Sample Parameter Graph
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Plot Parameter Options
You have four parameter graph display options in 
RealMonitor’s Plot Parameter box:

Against. selects the x-axis units. Choose one of the following: 

■ Time Stamp (default), the actual times data points were 
logged

■ Time Elapsed, the time elapsed since the start of build 
when data points were logged

■ Stage Height Z, the z-height when data points were 
logged.

Actual Value  displays parameter actual value curve.

Set Point  displays parameter set point value curve.

Average Over [number of data points]  displays parameter moving average curve. 
Use this moving average curve to help detect trends you might not see on the Actual 
Value curve. The moving average is calculated for the most recent number of data 
points. The default = 120 data points. You can change the moving average number of 
data points in the RealMonitor Preferences window. (See “RM Settings Preferences 
Tab” on page 93.)
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Events
RealMonitor tracks a number of events during a build. Events are marked with a 
vertical line, and an abbreviation (above the line). The line and abbreviation are also 
color coded. The following table shows the monitored events:

Abbreviation Event Description

PM Pause Monitor Monitoring was paused.

SR Sample Rate The sampling rate was changed by the user.

BP Build 
Parameter

A build parameter was manually adjusted.

PP Part Parameter A part parameter was manually adjusted.

BM Build Mode The build mode was manually adjusted

AD Add/Delete 
Parts

Parts were manually added or deleted

PC Prime Cycle A prime cycle was run.

NS Next Stage The system was manually directed to move to the 
next stage of the build.

TM Terminate The build was manually terminated.

AL Alarm A system alarm occurred.

R1 Calibration on The system began real-time calibration.

R0 Calibration off The system stopped real-time calibration.

RA Real-time 
adjustment

A calibration adjustment occurred.
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Zooming in X and Y
You can change the visible portion of either of the two graphs 
displayed in the RealMonitor window by clicking the Zoom X or 
Zoom Y toolbar button. 

After clicking Zoom X or Zoom Y, click on the graph where you want the zoom 
centered, then use the left and right mouse buttons to zoom in and out.

Use the mouse wheel, if available, to scroll within the graph. If you place the mouse 
inside the plot, the graph scrolls along the X axis. Placing the mouse on the left side 
of the plot allows you to scroll along the Y axis.

✏The Zoom X button changes the x-axis zoom on both graphs. The Zoom Y button on changes 
the y-axis of the graph you clicked on.

Setting the Y Scale Range  Click the Y-Scale toolbar button to display a 
dialog box with fields for minimum and maximum values of the Y axis for 
either of the two parameter graphs. (See Figure 39 below.)
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Click the Reset button to return to the original zoom settings.

The Zoom Factors button reports the current zoom factors 
the x-axis (same for both graphs) and the separate zoom 
factors for the upper (Y1) and lower (Y2) graphs.

Figure 39. Y Scale Dialog Box
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Printing Plots
Click the Print toolbar button to display a dialog box of printing options. The system 
prints the two current graphs to the printer you select.

Setting Preferences
Click the Pref toolbar button to display a the RealMonitor Preference window. Set 
your preferences on any or all of the four Preference window tabs described below, 
then click OK to save them.

General Preferences 
Tab
Use this tab to enter 
company and machine 
information, select the 
display units, and choose 
the date and time format 
used to time stamp the 
data that RealMonitor logs.

✏The Machine Serial Number 
is read-only. It is set by 
3D Systems.
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Diskspace Manage 
Preferences Tab
Use this tab to specify 
limits—in number of files, 
megabytes (MB), or 
Days—on the amount of 
disk space session log 
files can occupy.

You can set three types of 
limits on both Build 
session files and Manual 
Ops session files. To set a 
limit, select can not 
exceed, then enter (or 
scroll to select) the limit 
value.

Number of 3DL files  Keeps the last m 3DL files on disk, where m is between:

■ 10 and 10000 Build session log files; default m = 100 files

■ 5 and 10000 Manual Ops session log files; default m = 5 files

When the number of session log files on disk equals the limit m, the oldest (based 
on time stamp) is deleted when a new file is added.

Total 3DL file size  Keeps up to n MB of session log files on disk, where n is between:

■ 500 MB and 1000000 MB (1000 GB) Build session log files; default 
n = 1000 MB (1 GB).
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■ 500 MB and 1000000 MB (1000 GB) Manual Ops session log files; default n = 
500 MB.

When the amount of disk space used by session log files exceeds the n MB limit, 
the oldest file(s) (based on time stamp) are deleted until disk space used drops 
below n MB.

3DL file life age  Keeps up to d Days of 3DL files on disk, where d is between:

■ 10 and 10000 Build session log files; default m = 100 files

■ 5 and 10000 Manual Ops session log files; default m = 5 files

When the number of days exceeds the limit d, any files with a time stamp older 
than d Days are deleted. 

RM Settings Preferences Tab
Use this tab to set the following:

Average Data Points  The default number 
of data points over which RealMonitor 
calculates the moving average plotted on 
parameter graphs. (See “Average Over 
[number of data points]” on page 87.)

Hint text stay for  The number of seconds 
hint text remains visible when you pointer 
hovers a RealMonitor toolbar button.

Color Settings  Lets you set different 
colors for the Actual Value, Average 
Value, and Setpoint curves in RealMonitor 
parameter graphs. Click the  button to 
choose a color.
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RM Events Preferences Tab
Use this tab to select the Events you want 
RealMonitor to show. The events you 
select are highlighted on RealMonitor’s 
parameter graphs with vertical lines and 
two-letter abbreviations. For event 
descriptions, see “Events” on page 88.

Creating a Session Log File Manually
Use RealMonitor’s W3DL toolbar button to manually create a session log 
(3DL) file for the current log session. When you click the W3DL button, 
RealMonitor does the following:

■ Closes the current 3DL file if a session is in progress and writes the file to disk, 
time-stamping it with the current time.

■ Opens a new (Build or Manual Ops) 3DL file (depending on which mode Sinter is 
in) and begins logging data in this new 3DL file.



Chapter 10
LogManager
This section describes LogManager, a stand-alone Sinter application utility program 
that lets you view and search the contents of 3DL Session Log Files. You launch 
LogManager separate from Sinter. It runs in a window with several tabs; one for each 
log file Sinter generates. 

✏LogManager replaces the older RealMonitor Viewer and BrowseLog utilities. It handles all of 
their functions and adds some new ones.

You need a RealMonitor license to take full advantage of LogManager. You can view 
and search text data stored LogManager without a license. With a license, you can 
also view parameter data plots of RealMonitor log file data. 

This section includes the following topics:

■ RealMonitor License for LogManager

■ About LogManager

■ Starting LogManager

■ LogManager Window

■ LogManager Menus

■ LogManager Log Tabs

■ Time-Tracking Log File Data

■ Synchronizing Multiple LogManager 
Windows

■ Time Zone Localization

■ Opening Individual Log Files

■ Comparing Parameters in 
LogManager

■ Printing Plots

■ RealMonitor Log Viewing Options
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RealMonitor License for LogManager
LogManager and RealMonitor are licensed applications. You only need one license—
a RealMonitor license—to make full use of both LogManager and RealMonitor.

You can log data about your system before you install a RealMonitor license, but you 
must install a license before you can view data plots in LogManager and RealMonitor. 

See “RealMonitor License” on page 80 for a complete information on the RealMonitor 
license for LogManager, including:

■ Installing a RealMonitor License so you can access all functionality in LogManager

■ What a RealMonitor License Enables in the LogManager utility

■ Replacing a RealMonitor License if necessary

About LogManager
LogManager enables you to do the following:

■ Open Build and Manual Ops Session Log Files (3DL files) and view their contents.

■ Open and view individual Sinter error and monitoring log files, such as 
RealMonitor log (.rmt) files, Slicer (.tlog) files, and States log (.blog) files.

Unlike the RealMonitor utility, you don’t need to run Sinter to start LogManager.
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Starting LogManager
You can start LogManager from your Windows Start menu by choosing Programs > 
SLS System > LogManager. You can also start LogManager by double-clicking one 
of the following log files in Windows Explorer:

■ Build or Manual Ops 3DL file in ..\dtm\3DLogs\Build or ..\dtm\3DLogs\ManualOps

■ RealMonitor (.rmt) log file in ..\dtm\logs\RMData 

■ States log (.blog) file in ..\dtm\Logs

Windows should launch LogManager with the selected log file loaded. 

LogManager will run on your SLS system computer while Sinter and RealMonitor are 
running—or not. Or, you can run LogManager on a stand-alone computer separate 
from the SLS system.

Running Multiple Instances of LogManager
LogManager opens Session Log Files (“3DL files”) one at a time, but you can run 
multiple “instances” of LogManager (i.e., “open several LogManager windows”) on a 
single computer. This is useful if you want to:

■ View several 3DL files at once

■ View one 3DL file several different ways

In addition, LogManager lets you “synchronize” multiple instances of LogManager to 
make it easier for you to compare data values that were logged at the same time and 
date. See “LogManager Log Tabs” on page 106 for further information.
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LogManager Window
After you start LogManager, a single window opens (Figure 40 below). If you open a 
3DL session log file (using File > Open), several “log tab” buttons appear along the 
top of the window. Each tab button corresponds to an individual log file stored in the 
3DL session log file you opened. (If you open an individual log file instead of a 3DL 
file, only one log tab button appears.)

Figure 40. LogManager window (showing RealMonitor tab view for RealMonitor log (.rmt) file)

Log Tab buttons Action Bar

Summary:
Machine 
information

Main 
Display

Summary:
Build 
information

Menus
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LogManager Window Elements
Each LogManager window element shown in Figure 40 is described in this section.

Log Tab Buttons
Use Log Tab buttons to view all available data in the currently loaded individual log 
file or 3DL session log file. When you open a log file in LogManager, you only see Log 
Tab buttons corresponding to the data in that log file.

3DL session log files typically have more Log Tab buttons than individual log files. 
However, Manual Ops 3DL files have fewer Log Tab buttons than Build 3DL files, 
because Manual Ops 3DL files do not contain RealMonitor data. 

See “LogManager Log Tabs” on page 106 for further information.

Menus
See “LogManager Menus” on page 104.

Action Bar Buttons
The Action Bar buttons operate on the data your currently viewing in the Main 
Display. For example, buttons on the RealMonitor tab’s Action Bar enable you to 
zoom and scale parameter data plots. Action Bar buttons on other Log Tabs enable 
you to manipulate your view of text data; for example, Search, Collapse, and Expand 
text data entries.

See “LogManager Log Tabs” on page 106 for descriptions of Action Bar buttons in 
the various Log Tabs.

Main Display
This is where the actual file content is displayed. There are various Main Display 
formats in LogManager. The one you see depends on the type and content of the file 
you are viewing.
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The following describes the different types of Main Displays you see when viewing 
different types of files in LogManager:

■ When viewing RealMonitor Log (.rmt) file data, you see data plots in the Main 
Display on the RealMonitor tab.

■ When viewing States Log (.blog) file data—or data from other log (.tlog) files 
containing ISO-formatted time-stamped entries—the Main Display shows 
clickable time-stamped data item entry lists along with the contents of the 
selected entry. You can select, browse, and search through time stamped entries 
in these files. This Main Display format is used on the following Log Tabs: 
StatesLog, Realtime IR Cal, IR Adjustment, PLCIF, ScanIF, Slicer, DutyCylAdj, and 
BDS. (See Figure 41., “StatesLog tab for States Log (.blog) file,” on page 101 for an 
example of the StatesLog Main Display.)

✏ ISO (International Standards Organization) time stamp format is
YYYY-MM-DD_HHMMSS —> Message. 

■ The Main Displays for other types of files you can view in LogManger, such as .ini 
files and machine and build data files, are either tabular, or simple text listings. 
These Main Display formats are found on the following Log Tabs: IR Cal Ini, IR 
Offline Cal, Machine Overlay, and Build History.
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Figure 41. StatesLog tab for States Log (.blog) file

StatesLog tab selected Expand/Collapse buttons
(view more/less in Summary) 

Search 
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Main 
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Summary 
(data for 
selected 
entry on 
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Currently selected entry
(data displayed in Summary on the right)
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Summary Windows – (RealMonitor Tab Only)
Two Summary windows at the top of the RealMonitor tab Main Display list identifying 
information for the machine and build that generated the log file you are viewing.

Summary: Machine information
■ Platform Type – the SLS system model on which this data was logged:

■ Sinterstation HiQ or HiQ +HS

■ Vanguard or Vanguard HS, or 

■ Sinterstation 2500plus

■ Machine Name – the Machine Name you entered on the General Preferences Tab 
in RealMonitor.

■ Machine Serial Number – the (read-only) Machine Serial Number shown on the 
General Preferences Tab in RealMonitor. (The serial number is set by 
3D Systems.)

■ Customer Name – the Company Name you entered on the General Preferences 
Tab in RealMonitor.

■ Material Name – the default material selected when this log file was generated. 
(This value is in the material configuration file, material_name.cfg.)

■ Material File Name – the material configuration file name, material_name.cfg, for 
the default material selected when this log file was generated.

■ Sinter Version – the Sinter application software version that generated the log file 
you are viewing.
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■ Build Setup Version – the Build Setup application software version that created 
the build packet “Build Packet Name” above. If you are viewing a Manual Ops 
session 3DL file, the Build Setup Version is always “NA” (Not Applicable).

■ Slicer Time Stamp – the time stamp for the start of the Slicer software module as 
recorded in the log file.

Summary: Build information
■ Build Packet Name – the name of the build packet that generated this log file. If 

you are viewing a Manual Ops session 3DL file, the Build Packet Name is always 
“Manual Ops.”

■ Build Finish Status – build termination status; “Normal” if the build finished 
normally; “Abnormal” if the build started, but did not finish normally.)

■ Start Log At – the time RealMonitor started logging to this log file. 

■ End Log At – the time RealMonitor stopped logging to this log file. 

■ RM Start Log Event – the event that triggered the start of RealMonitor logging. 
(See RealMonitor build “Events” on page 88.)

■ RM End Log Event – the event that triggered the end of RealMonitor logging. (See 
RealMonitor build “Events” on page 88.)

■ RM Sample Rate – the number of seconds between consecutive RealMonitor log 
entries (or “samples”) in this log file.

■ RM Config File – the name of the active RealMonitor configuration file when this 
log file was generated.
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LogManager Menus
Commands on each LogManager menu are described below.

File Menu
■ Open ... opens 3DL files, or individual log files such as Real Monitor file, States 

Log File etc.

■ Recent Files ... lists the filenames and time stamps of the 10 most recently viewed 
3DL file(s) in this instance of LogManager.

■ Export – saves the log file data you are currently viewing to tab-delimited ASCII 
text file (requires RealMonitor License).

■ Print – prints the data in the Log Tab Main Display you are currently viewing. If you 
are viewing parameter graphs on the RealMonitor tab’s Main Display, you can 
print both graphs to a printer or a bitmap file.

■ Preference – opens LogManager’s Preference window. The settings in this 
window are a subset of those in RealMonitor’s Preference window. See “Setting 
Preferences” on page 91 in Chapter 9, “RealMonitor”  for preference setting 
descriptions and instructions.

■ Exit – exits the currently selected LogManager instance. (All other running 
instances remain open.)

Options Menu
The time tracking and synchronization commands on this menu help you compare 
data in individual log files within one 3DL session and across multiple 3DL sessions.

■ Time Tracking – automatically selects the same entry time stamp in every Log 
Tab, based on your current entry selection. See “LogManager Log Tabs” on 
page 106.
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■ Time Synchronization – automatically sets the same data view settings in all 
open, running LogManager windows, based on the data view settings in the 
currently selected LogManger window. This works whether you’re viewing the 
same 3DL file in multiple windows, or different 3DL files in multiple windows. See 
“Synchronizing Multiple LogManager Windows” on page 119.

Windows Menu
These window resizing commands act on the currently selected instance of 
LogManager:

■ Default Size – set the LogManger window to its default size.

■ Maximize – enlarges the LogManager window to fill the display area.

■ Minimize – shrinks the LogManager window to a title bar at the bottom of the 
display.

Help Menu
■ About ... opens a window showing the LogManager software version number 

along with 3D Systems contact information.

■ Help ... displays the online documentation for LogManager.

■ License – displays the license password entry window for a RealMonitor License.
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LogManager Log Tabs
This section describes the views of log data you see under each Log Tab button in 
LogManager. The Action Bar and Main Display, which vary from one Log Tab to the 
next, are described separately for each Log Tab in LogManager.

RealMonitor Tab
The RealMonitor tab contains an Action Bar with buttons for manipulating the 
appearance of the two parameter graphs in its Main Display. It also contains Plot 
Parameter controls for changing the plotting options on the two graphs.

The RealMonitor tab displays the time-stamped contents of a RealMonitor log file; file 
name format MMDDYYbuildname.rmt. RealMonitor log files contain the values of all 
parameters RealMonitor acquires between the start and end of logging during a 
build.

RealMonitor Tab Action Bar Buttons
Use RealMonitor tab Action Bar buttons to adjust the parameter plot zoom, view 
Display Build Properties, and scroll the parameter graphs forward and back.

■ Zoom X – click this button, then click inside a parameter graph to 
interactively change the x-axis zoom factor for both the upper and 
lower graphs. (See “Zooming in X and Y” on page 89 for further 
information.)

■ Zoom Y – click this button, then click inside a parameter graph to interactively 
change that graph’s y-axis zoom factor. (See “Zooming in X and Y” on page 89 for 
further information.)
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■ Y-Scale – click this button to open the Y-Scale dialog box (see Figure 39 on 
page 90) and enter the upper and lower y-axis ranges for the two currently 
displayed parameter graphs. (See “Zooming in X and Y” on page 89 for 
further information.)

■ Reset – click to return to the original zoom settings.

■ Zoom Factors – shows the current zoom factors for the x- 
and y axes on both parameter graphs. (See “Zooming in 
X and Y” on page 89 for further information.)

RealMonitor Tab Main Display
The RealMonitor tab Main Display (see Figure 42 on page 108) contains two 
Summary windows; one for Machine information (on the left) and one for Build 
information (on the right). (See “Summary Windows – (RealMonitor Tab Only)” on 
page 102 for further information.) 

Below the Summary windows in the RealMonitor tab Main Display are two parameter 
graphs with Plot Parameter controls for setting plotting options.

✏The parameter graph and plotting options for the graphs in LogManager’s RealMonitor tab 
Main Display are the same as those for the parameter graphs in the RealMonitor utility. See 
“Parameter Graphs and Plotting Options” on page 86 in Chapter 9, “RealMonitor” for details 
and instructions.
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Figure 42. RealMonitor tab Main Display in LogManager
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StatesLog (.blog) File Tab
The StatesLog tab contains an Action Bar with buttons for manipulating the time-
stamped states log data entries listed in its Main Display window(s).

The StatesLog tab displays the contents of the log file, States.blog, which contains all 
Build, Part, and Scale & Offset parameter values.

StatesLog Tab Action Bar
■ Search – opens Search States Log window. (See Figure 43 

on page 110 below.) Use this window to find and select 
items to search for (“Search Items”) in the states log file. The 
search starts when you click OK to close the Search States Log window. The 
search results are shown in the StatesLog tab Main Display.

■ Next/Previous – search down (forward)/up (backward) for the next occurrence of 
the Search Items currently set in the Search States Log window (shown in (See 
Figure 43 on page 110 below).

■ Collapse/Expand – minimize (Collapse) or maximize (Expand) the 
amount of text data shown in the right Main Display pane for the 
currently selected states log Item/Time Stamp.
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StatesLog Tab Main Display
Description Main Display; (Short List) shows list of log file entries by Item # and time 
stamp on the left; right pane shows contents of single currently selected log file entry 
data. You can Search, Expand, and Collapse this. (List All) shows table of log data 
with Item #, Time Stamp, and data columns.

Figure 43. Search States Log window in StatesLog tab

Enter search string to search 
for items in list below you want 
to add to the Search Items

Select a Search Item, then click Delete 
to remove it from the Search Items list.

Click OK to 
start search

Select an 
item in this 
list, then 
click Add to 
add it to the 
Search 
Items list on 
the right.

List of 
Search 
Items
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Figure 44. StatesLog tab Main Display

Select an 
Item/
Time Stamp 
in list on the 
left to display 
Item’s data 
contents in 
the right.

Contains either:
(a.) The data 
contents for the 
currently 
selected Item/
Time Stamp on 
the left, or, 
(b.) The data 
contents for the 
Search Items 
found.
(Expanded 
view shown.)
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Time-Stamped Log (.tlog) File Tabs

Time-stamped log (.tlog) tabs in LogManager all have the same Action Bar buttons 
and Main Display. The Action Bar buttons change your view of the time-stamped text 
log data listed in the Main Display. A Search button is also included.

Time-stamped Log Tabs include:

Time-Stamped Log (.tlog) Tabs Action Bar
■ Short List – displays the time-stamped log file data in a left and 

right pane, similar to the StatesLog Main Display shown in Figure 
44 on page 111. You select an Item/Time Stamp on the left to 
display its contents on the right.

.tlog File Tab Displays Log File Log File Contains

Realtime IR Cal RealTimeCal.log Data for every Real Time Calibration event. For each 
calibration attempt, it logs whether calibration was successful 
or failed—and how much adjustment, if any, was applied—
and why.

IR Adjustment OfflineCal.log  For offline calibration only: Records how much adjustment 
was applied during any Offline Calibration—and why the 
adjustment was applied

PLCIF Plcif.tlog PLC interface program (Plcif.exe) runtime errors

ScanIF ScanIF.tlog Scanner interface program (Scanif.exe) runtime errors

Slicer Slicer.tlog Slicer program (Slicer.exe) runtime errors

DutyCylAdj

BDS Bds.tlog All commands sent to the beam delivery system by the 
scanner interface software
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■ List All – displays the time-stamped log file data in a scrollable table in a single 
pane.

■ Search – lets you search for a text string in the 
log file. Enter the text string in the search text 
box, then click the Search button. All Items 
containing the search string appear in the Main Display. Click the drop-down 
arrow on the Search button to change the search direction and turn case-
sensitivity on or off.
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Time-Stamped Log Tabs Main Display
The Main Display you see on time-stamped log tabs depends on whether you have 
the Short List or List All action bar button selected. 

List All Main DisplayShort List Main Display

Figure 45. Time-Stamped Log Tabs Main Display
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Machine Status File Tabs

Machine Status file tabs in LogManager all have the same Action Bar buttons and 
Main Display. The Action Bar buttons change your view of the text data listed in the 
Main Display. A text Search tool is also included.

Machine Status file tabs include:

Machine Status File Tabs Action Bar
■ Sel All – Select all text in file; click again to deselect all.

■ Search – Enter search text in the box; click 
Search to find all occurrences of the search 
text in the file. Search results are shown in the 
Main Display.

.tLog File Tab Displays Log File Log File Contains

IR Cal Ini IRCal.ini Current IR sensor scale values from latest IR calibration

IR Offline Cal IROfflineCal.log Manual offline IR calibration results

Machine Overlay machine.ovrl Machine overlay file listing
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Machine Status File Tabs Main Display

Figure 46. Machine Status File Tabs Main Display
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Build History File Tab
Unlike other Log Tabs in LogManager, the Build History tab has no Action Bar; only a 
table of build history data in the Main Display (Figure 47 on page 118). Each row in 
the table contains the build history data for one build. The top row always shows the 
history data for the most recent build. 

The columns in the build history table list the following data for each build:

End Build Time Time-stamp for the Build End event

Build Height Total height of the build; number of layers X layer thickness

Part Temp-0.25” Part bed temperature recorded by the Part IR sensor 0.25 inches into the build

Left Temp-0.25” Left feed temperature recorded by the left feed IR sensor 0.25 inches into the build

Right Temp-0.25” Right feed temperature recorded by the right feed IR sensor 0.25 inches into the build

Part Temp-End Part bed temperature recorded by the Part IR sensor at the end of the build

Left Temp-End Left feed temperature recorded by the left feed IR sensor at the end of the build

Right Temp-End Right feed temperature recorded by the right feed IR sensor at the end of the build

Material Default material selected in Sinter when this build was run
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Build History Tab Main Display

Figure 47. Build History File Tab Main Display

One row of data 
per build

End of Build time-stamp Part bed and feed temperatures Default material
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Time-Tracking Log File Data
Select Options Menu > Time Tracking to automatically select the same entry time 
stamp in every Log Tab. This helps you compare data in different log files that was 
recorded at the same time.

To see how this works, try the following with Time Tracking selected:

1. Click on a time-stamped log file entry in the current Log Tab.

2. Click on a different Log Tab button; one for a log file that has time-stamped 
entries.

3. Note that the same entry time stamp is selected in the new Log Tab.

Synchronizing Multiple LogManager Windows
Select Options Menu > Time Synchronization to automatically sets the same data 
view settings in all open, running LogManager windows, based on the data view 
settings in the currently selected LogManager window. 

Time Synchronization helps you compare data, whether you’re viewing the same 
3DL file in multiple windows, or different 3DL files in multiple windows.

✏You must have log files loaded in two or more LogManager windows to use this feature.

When you select Options > Time Synchronization, LogManager matches the views 
of the data items below in all open LogManager windows with your view of these 
items in the currently selected (“focused”) LogManager window. 

■ View data – The specific Log Tab currently in view, such as the RealMonitor tab or 
StatesLog tab.

■ X Scale - The x scale (zoom factor) of the data plots on the RealMonitor tab

■ Y Scale - The y scale (zoom factor) of the data plots on the RealMonitor tab.
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■ Currently focused time – If you have multiple LogManager windows open and to 
view:

■ The same 3DL file – the focused time stamp in the focused LogManager 
window sets the focused time stamp in all other open LogManager windows 
viewing that same 3DL file. 

■ Multiple 3DL files – the 3DL files in all open LogManager windows are set to 
the same time into the build as the 3DL file in the focused LogManager 
window.

If you select a different LogManager window, then select Options > Time 
Synchronization in that window, it now becomes the focused window that the other 
open windows track.
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Time Zone Localization
The date and time stamps in the log file can be recorded at different time zones. The 
date and time stamps in the file name will always be in the time zone which has been 
recorded. However, we will have an option to display the date and time in either the 
local time or original time within the LogManager program. This option should be set 
in the preference section and should be persistent.

Opening Individual Log Files
As we mentioned before the Log Manager can open individual log files such as Real 
Monitor Log files, States Log Files, or other error log files. There will only be two 
cases you will need to open individual files:

■ Οpen legacy log files. Those log files was created before this change can be 
opened as individual log file use this utility.

■ Οpen individual log files during a log session. In this case, the 3DL file has not yet 
been generated. When the user chooses to open this type of log file, a copy of the 
log file is opened instead of the original so that the logging can continue without 
interruption. Therefore the file you opened will be a snapshot of the time that you 
opened it. Any new log data after you opened the file will not be refreshed into the 
display.

Comparing Parameters in LogManager
While LogManager’s RealMonitor Tab and the RealMonitor utility in Sinter both 
display the same parameter data plots. This enables you to view and compare two 
machine parameters over time. 

However, if you want to compare more than two parameters, you can launch 
additional instances of LogManager, load the same log file in each window, then 
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select different parameters to view in each window’s RealMonitor tab.

✏See “Parameter Graphs and Plotting Options” on page 86 and “Events” on page 88 in for 
further information about comparing parameters on RealMonitor parameter graphs.

Printing Plots
Select File > Print in the LogManager window to print both two parameter graphs 
currently displayed in the RealMonitor tab. You can print the graphs to a printer or to 
bitmap file.

RealMonitor Log Viewing Options in LogManager
You can use LogManager to view log files (.rmt files) generated by RealMonitor from 
past builds. LogManager also has other features for viewing data that are not 
available in RealMonitor.

Loading an Individual RealMonitor Log (.rmt) File
As an alternative to loading an entire Build session 3DL file, you can load an 
individual RealMonitor log (.rmt) file in LogManager if you just want to view 
RealMonitor parameter graphs. Use File > Open in LogManager open an individual 
RealMonitor log (.rmt) file to view. RealMonitor data files are stored in the 
\dtm\logs\RMData folder by default.

✏The Action Bar buttons on the RealMonitor tab remain inactive until you load a RealMonitor 
log file, (or a Build session 3DL file that contains a RealMonitor log file).

✏See Figure 42., “RealMonitor tab Main Display in LogManager,” on page 108.
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View Pinpoint Data
To get more specific information about a 
point on a data plot on the RealMonitor 
tab, hover your mouse pointer over the 
point, or click on the point:

■ When you pause your mouse pointer 
over a point on the plotted graph, 
information about the data point 
appears in a pop up window, including 
its value (y), time (x), stage height and 
set point, as well as an average value 
created by averaging the current point 
with some number of preceding points 
(defined by the Average Data Points 
preference option). If an event is 
associated with the data point, the event description also appears.

■ When you click on a point on the curve, green horizontal and vertical lines 
pinpoint your location, and the application displays a popup window with 
information about the selected point. When you have selected a point in this way, 
you can move the selection forward or backward through the graph with the 
arrow keys on your keyboard.

Display Build Properties
Click the Property button in on the RealMonitor tab’s Action Bar to display a 
dialog box with information about the build whose data you are viewing. 
Basic information such as the platform, machine name, and material type is 
displayed at the top of the window, with details such as build and part parameters 
displayed in tabs at the bottom.

Figure 48. Hover pointer to view pinpoint data
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Exporting Data Files
If you have an RealMonitor license installed on the computer that LogManager is 
running on, you can export data from LogManager. Select File > Export from the 
LogManager menu to save data from the currently loaded log file to a text file.

Click tabs to 
display different 
categories of 
information

Print the data or 
save it to a file

Figure 49. Properties Window
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3DL files  70, 71

disk space management  92

A
Action Bar (in LogManager)  99

machine status file tabs  115
RealMonitor tab  106
StatesLog tab  109
time-stamped log (.tlog) tabs  112

activation password, for license
RealMonitor  81

address book, creating  19

B
Build History tab (in LogManager)  117

Main Display  118
Build Parts window, in Remote Status 
utility  37
build properties, displaying (in 
LogManager)  123
Build Report utility

about  46
generating reports  47
units used  53

using reports  53
Build Report Utility window  47
Build session log file  71, 78
build, tracking with Remote Status  36

C
code book, creating  15
collapse button, StatesLog tab  101
command-line options  41
comparing parameters (in 
LogManager)  121
computer ID, for RealMonitor license  
81
Connection dialog box  34
consequences of events  5
custom reports  47

D
dialog boxes

Connection  34
Display Properties  33
Edit Address Book  20
Edit Phone Book  13
Edit Phone Book Entry  14
Edit Program Book  25
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Edit Z Height Triggers  29
Mail Setup  19
Mailing List  23
Output Options  51
Pager Setup  11
Paging List  17
Preferences  49
Program List  28

disk space management, 3DL files  92
Display Properties dialog box  33
Dtm menu  2
DTMRuntracker workbook

about  55
minimum requirements  56
setting up  59

E
Edit

Address Book dialog box  20
Phone Book dialog box  13
Phone Book Entry dialog box  14
Program Book dialog box  25
Z Height Triggers dialog box  29

e-mail notification, setting up  18
error log files  73
events  94

descriptions (in RealMonitor)  88
RM End Log  103
RM Start Log  103

events, that can trigger notification  5

Excel, Solver add-in  56
expand button, StatesLog tab  101
export, log file data in LogManager  104
exporting log files  124

F
File menu, in LogManager  104

G
Gettimes

command-line options  41
running  41
sample output  43

getting started  2
graphs, for parameters

historical (in LogManager)  107
real-time (in RealMonitor)  86

H
Help menu, in LogManager  105

I
input file, changing name in Gettimes  
41
introduction  1

L
license
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activation password for  81
license, RealMonitor

for LogManager  96
for RealMonitor  81
installing  80

log files
3DL  70, 71
Build session  71
error logs, types of  73
individual, opening in LogManager  

121
Manual Ops session  71
monitoring logs, types of  73
RealMonitor (.rmt)  83
session, see session log files

log sessions  74, 76
log tabs

Build History tab  117
buttons (in LogManager)  98, 99
buttons, in LogManager  106
machine status file tabs  115
RealMonitor tab  106
StatesLog tab  109
time-stamped log (.tlog) tabs  112

LogManager  95–124
Action Bar  98
comparing parameters in  121
exporting log files  124
File menu  104
Help menu  105

log tabs  106
Options menu  104
running multiple instances 

(windows)  97
starting  97
window elements  98, 99
Windows menu  105

M
machine status file tabs (in 
LogManager)

Main Display  116
machine status file tabs, in LogManager  
115
mail server  19
Mail Setup dialog box  19
Mailing List dialog box  23
mailing lists, creating  22
Main Display (LogManager)  99

Build History tab  118
machine status file tabs  116
RealMonitor tab  98, 107
StatesLog tab  101, 110
time-stamped log (.tlog) tabs  114

Manual Ops session log file  71, 78
menus, in LogManager  104
Microsoft Excel workbooks  55
modem IP address  11
monitoring log files  73
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O
opening log files  121
optimizing STL files  65
Options menu, in LogManager  104
output file, changing name of in 
Gettimes  42
Output Options dialog box  51

P
pager lists, creating  15
pager notification, setting up  8
Pager Setup dialog box  11
pager, setting up  11
Paging List dialog box  17
parameter graphs (in RealMonitor)  86
parameters, comparing (in 
LogManager)  121
phone book, creating  13
plots

parameter
in LogManager (historical)  108
in RealMonitor (real-time)  86

printing
in LogManager  122
in RealMonitor  91

point data, viewing (in RealMonitor or 
LogManager)  123
Preferences dialog box  49
preferences, LogManager  104
preferences, RealMonitor  91–94

disk space management  92
events  94
general  91
RM settings  93

Prgram List dialog box  28
Print  91
printing plots

in LogManager  122
in RealMonitor  91

program book, creating  24
program lists, creating  26
programs, setting up  23
Property button, RealMonitor tab 
(LogManager)  123

R
RealMonitor  79–94

comparing parameters  85
End Log Event  103
events  88
license

computer ID for  81
for RealMonitor & LogManager  

80, 96
installing  80
network configuration  82
what it enables  81

log (.rmt) file  83
loading in LogManager  122

logging data with  83
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parameter graphs  86
printing  91

preferences, setting  91–94
sample rate  103
Start Log Event  103
tab (in LogManager)  106

RealMonitor tab (in LogManager)  106, 
107

build properties  123
Main Display  107

Remote Notification
consequences  5
creating

address book  19
code book  15
mailing lists  22
pager lists  15
phone book  13
program book  24
program lists  26

events  5
introduction  3
printing settings from  7
setting up

e-mail  18
e-Mail notification  18
pager  11
pager notification  8
programs  23
Z-height triggers  28

settings files  5

starting  4
storing setup information  5

Remote Status
changing your font setting  32
installing on a client system  32
problems  32
starting  34
tracking a build  36
using  36
viewing a Status window  38

RemoteNotify window  4
Reset (zoom) button (LogManager, 
RealMonitor tab)  107
resetting zoom, RealMonitor  90
RM (RealMonitor) End Log Event  103
RM (RealMonitor) Sample Rate  103
RM (RealMonitor) Start Log Event  103

S
sample rate, in RealMonitor  103
Scale-Offset II workbook

about  55
minimum requirements  56
setting up  59

search
StatesLog tab  101
stateslog.blog  101

session log files  70–78
contents  72
disk space management  77
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file name formats  75
generating manually  75, 94
how generated  74

Setting  18
settings files  5
Socket Port text box  12
Solver add-in, for Excel  56
Start menu  2
starting the utilities  2
states.blog file  40, 42, 53
StatesLog

tab (in LogManager)  101, 109
Main Display  110

stateslog.blog  101
Status window  38
STL File Optimization Utility window  
65, 66
STL files  63, 70, 79
STL Optimization Utility  63, 70, 79
storing setup information  5
Summary (in LogManager)

RealMonitor tab  98, 102
build information  103
machine information  102

StatesLog tab  101
synchronizing LogManager windows  
119

T
time sychronization (in LogManager)  

119
time synchronization (in LogManager)  
105
time tracking (in LogManager)  104, 119
time zone localization (in LogManager)  
121
time-stamped log (.tlog) file tabs (in 
LogManager)  112

Main Display  114
tracking a build  36

V
viewing a Status window  38
viewing pinpoint data (in RealMonitor 
or LogManager)  123

W
W3DL button, in RealMonitor  94
windows

Build Parts  37
Build Report Utility  47
RemoteNotify  4
Status  38
STL File Optimization Utility  65, 66

Windows menu, in LogManager  105
workbooks  55
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button (LogManager, RealMonitor 
tab)  107

range, setting for RealMonitor 
graphs  89

Z
Z-height triggers, setting up  28
Zoom X button (LogManager, 

RealMonitor tab)  106
Zoom Y button (LogManager, 
RealMonitor tab)  106
zoom, RealMonitor graphs
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X and Y axes  89
Y-Scale range  89
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